Is there any requirement on computer hardware when I use your product?

yifangyunCreated at:Jan 02, 2019 11:38:18

Web version: We suggest that you use Google Chrome or Firefox characterized by relatively high compatibility (IE11 and higher editions are supported)

PC version: Windows xp SP3/7/8.1/10 server03/08/10 (including the latest 32-bit and 64-bit editions); Mac os X 10.10 and above (including 10.10); Linux and Unix operating systems are not supported.